const regex = /(?:^|[?&])token=([^&]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[?&])token=([^&]*)', 'gm')
const str = `key1=val1&token=val2&key3=val3
token=val1&key2=val2&key3=val3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}