re = /(\r|\n| |\t)+\<Grid(\r|\n| |\t)+Grid\.Row="0"(\r|\n| |\t)+IsVisible="False"(\r|\n| |\t)+Style="\{StaticResource(\r|\n| |\t)+MadressahFilterPickerGridBackgroundStyle\}"\>/
str = ' <Grid Grid.Row="2" Grid.Column="2" RowSpacing="0">
<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
</Grid.RowDefinitions>
<Grid Grid.Row="0" Style="{StaticResource MadressahFilterPickerGridBackgroundStyle}">
<StackLayout Orientation="Horizontal">
<StackLayout.GestureRecognizers>
<TapGestureRecognizer Tapped="ParentTapGestureRecognizer_Tapped" />
</StackLayout.GestureRecognizers>
<Label x:Name="parentName" Text="{Binding ParentPicker}"
BindingContext="{ Binding Source={x:Reference Root}, Path=BindingContext}"
Style="{StaticResource MadressahFilterPickerLabelStyle}" LineBreakMode="NoWrap"/>
<Label Style="{StaticResource MadressahPickerArrowStyle}" />
</StackLayout>
</Grid>
<Grid Grid.Row="0" IsVisible="False"
Style="{StaticResource MadressahFilterPickerGridBackgroundStyle}">
<Picker x:Name="parentList" Title="{i18n:Translate selectparent}"
ItemsSource="{Binding ParentList}"
ItemDisplayBinding="{Binding FullName}"
SelectedItem="{Binding ParentSelected}"
BindingContext="{ Binding Source={x:Reference Root}, Path=BindingContext}" />
</Grid>
</Grid>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end