// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(\r|\n| |\t)+\<Grid(\r|\n| |\t)+Grid\.Row="0"(\r|\n| |\t)+IsVisible="False"(\r|\n| |\t)+Style="\{StaticResource(\r|\n| |\t)+MadressahFilterPickerGridBackgroundStyle\}"\>"#).unwrap();
let string = " <Grid Grid.Row=\"2\" Grid.Column=\"2\" RowSpacing=\"0\">
<Grid.RowDefinitions>
<RowDefinition Height=\"Auto\" />
</Grid.RowDefinitions>
<Grid Grid.Row=\"0\" Style=\"{StaticResource MadressahFilterPickerGridBackgroundStyle}\">
<StackLayout Orientation=\"Horizontal\">
<StackLayout.GestureRecognizers>
<TapGestureRecognizer Tapped=\"ParentTapGestureRecognizer_Tapped\" />
</StackLayout.GestureRecognizers>
<Label x:Name=\"parentName\" Text=\"{Binding ParentPicker}\"
BindingContext=\"{ Binding Source={x:Reference Root}, Path=BindingContext}\"
Style=\"{StaticResource MadressahFilterPickerLabelStyle}\" LineBreakMode=\"NoWrap\"/>
<Label Style=\"{StaticResource MadressahPickerArrowStyle}\" />
</StackLayout>
</Grid>
<Grid Grid.Row=\"0\" IsVisible=\"False\"
Style=\"{StaticResource MadressahFilterPickerGridBackgroundStyle}\">
<Picker x:Name=\"parentList\" Title=\"{i18n:Translate selectparent}\"
ItemsSource=\"{Binding ParentList}\"
ItemDisplayBinding=\"{Binding FullName}\"
SelectedItem=\"{Binding ParentSelected}\"
BindingContext=\"{ Binding Source={x:Reference Root}, Path=BindingContext}\" />
</Grid>
</Grid>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}