package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<VirtualHost\s\*:9007>[\s\S]*?[^#]\s<Directory\s)[\/._a-z]+(>[\s\S]*?<\/VirtualHost>)`)
var str = `<VirtualHost *:80>
ScriptAlias /cgi-bin /var/www/cgi-bin
ServerName lp.kyivstar.net
DocumentRoot /var/www/kyivstar.net/public_html
<Directory /var/www/kyivstar.net/>
Options +ExecCGI -Indexes
AllowOverride All
Order allow,deny
Allow from all
SetHandler application/x-httpd-php-7.4.0
</Directory>
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
<VirtualHost *:9007>
ScriptAlias /cgi-bin /var/www/cgi-bin
DocumentRoot /var/www/test.loc/public_html
#<Directory /var/www/test2.loc/>
<Directory /var/www/test.loc/>
Options +ExecCGI -Indexes
AllowOverride All
Order allow,deny
Allow from all
SetHandler application/x-httpd-php-7.3.6
</Directory>
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
<VirtualHost *:443>
</VirtualHost>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}