import Foundation
let pattern = ##"(<VirtualHost\s\*:9007>[\s\S]*?[^#]\s<Directory\s)[\/._a-z]+(>[\s\S]*?<\/VirtualHost>)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<VirtualHost *:80>
ScriptAlias /cgi-bin /var/www/cgi-bin
ServerName lp.kyivstar.net
DocumentRoot /var/www/kyivstar.net/public_html
<Directory /var/www/kyivstar.net/>
Options +ExecCGI -Indexes
AllowOverride All
Order allow,deny
Allow from all
SetHandler application/x-httpd-php-7.4.0
</Directory>
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
<VirtualHost *:9007>
ScriptAlias /cgi-bin /var/www/cgi-bin
DocumentRoot /var/www/test.loc/public_html
#<Directory /var/www/test2.loc/>
<Directory /var/www/test.loc/>
Options +ExecCGI -Indexes
AllowOverride All
Order allow,deny
Allow from all
SetHandler application/x-httpd-php-7.3.6
</Directory>
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
<VirtualHost *:443>
</VirtualHost>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}