use strict;
my $str = '<VirtualHost *:80>
ScriptAlias /cgi-bin /var/www/cgi-bin
ServerName lp.kyivstar.net
DocumentRoot /var/www/kyivstar.net/public_html
<Directory /var/www/kyivstar.net/>
Options +ExecCGI -Indexes
AllowOverride All
Order allow,deny
Allow from all
SetHandler application/x-httpd-php-7.4.0
</Directory>
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
<VirtualHost *:9007>
ScriptAlias /cgi-bin /var/www/cgi-bin
DocumentRoot /var/www/test.loc/public_html
#<Directory /var/www/test2.loc/>
<Directory /var/www/test.loc/>
Options +ExecCGI -Indexes
AllowOverride All
Order allow,deny
Allow from all
SetHandler application/x-httpd-php-7.3.6
</Directory>
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
<VirtualHost *:443>
</VirtualHost>';
my $regex = qr/(<VirtualHost\s\*:9007>[\s\S]*?[^#]\s<Directory\s)[\/._a-z]+(>[\s\S]*?<\/VirtualHost>)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}