#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:A=)([^,]*))"
Local $sString = ""A=1,B=2,C=3"," & @CRLF & _
""A=11,B=12,C=13,D=15"," & @CRLF & _
""A=5,B=4,C=9,D=10,E=13"," & @CRLF & _
""A=19,B=20,C=91,D=40,E=33"," & @CRLF & _
""A=77,B=27,C=37""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")