// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:(?:A=)([^,]*))").unwrap();
let string = "\"A=1,B=2,C=3\",
\"A=11,B=12,C=13,D=15\",
\"A=5,B=4,C=9,D=10,E=13\",
\"A=19,B=20,C=91,D=40,E=33\",
\"A=77,B=27,C=37\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}