re = /(?:(?:A=)([^,]*))/m
str = '"A=1,B=2,C=3",
"A=11,B=12,C=13,D=15",
"A=5,B=4,C=9,D=10,E=13",
"A=19,B=20,C=91,D=40,E=33",
"A=77,B=27,C=37"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end