import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:A=)([^,]*))";
final String string = "\"A=1,B=2,C=3\",\n"
+ "\"A=11,B=12,C=13,D=15\",\n"
+ "\"A=5,B=4,C=9,D=10,E=13\",\n"
+ "\"A=19,B=20,C=91,D=40,E=33\",\n"
+ "\"A=77,B=27,C=37\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}