using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+\.mydomain\.com)$";
string input = @"fdf.mydomain.com
fred.mydomain.com
mydomain.com
fdf.com
.mydomain.com
gggg.mydomain.co.uk
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}