re = /^(.+\.mydomain\.com)$/m
str = 'fdf.mydomain.com
fred.mydomain.com
mydomain.com
fdf.com
.mydomain.com
gggg.mydomain.co.uk
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end