package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+\.mydomain\.com)$`)
var str = `fdf.mydomain.com
fred.mydomain.com
mydomain.com
fdf.com
.mydomain.com
gggg.mydomain.co.uk
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}