$re = '/^(.+\.mydomain\.com)$/m';
$str = 'fdf.mydomain.com
fred.mydomain.com
mydomain.com
fdf.com
.mydomain.com
gggg.mydomain.co.uk
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);