#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![,.])\d+(?:[,.-]\d+)? ?- ?\d+(?:[,.]\d+)? km ?\/ ?(?:h|\d+min)\b"
Local $sString = "The car drives 50,5 - 80 km/10min on the road." & @CRLF & _
"The car drives 50,5 - 80 km / 10min on the road." & @CRLF & _
"The car drives 40,5-80 km/h on the road." & @CRLF & _
"The car drives 30-50 km/h on the road." & @CRLF & _
"The car drives 40 - 60.8 km/ h on the road." & @CRLF & _
"The car drives 40.90-60,8 km/h on the road." & @CRLF & _
"The car drives 50,5 - 80 km/10 on the road." & @CRLF & _
"The car drives 505,000.2 - 80 km/10min on the road." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")