# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<![,.])\d+(?:[,.-]\d+)? ?- ?\d+(?:[,.]\d+)? km ?\/ ?(?:h|\d+min)\b"
test_str = ("The car drives 50,5 - 80 km/10min on the road.\n"
"The car drives 50,5 - 80 km / 10min on the road.\n"
"The car drives 40,5-80 km/h on the road.\n"
"The car drives 30-50 km/h on the road.\n"
"The car drives 40 - 60.8 km/ h on the road.\n"
"The car drives 40.90-60,8 km/h on the road.\n"
"The car drives 50,5 - 80 km/10 on the road.\n"
"The car drives 505,000.2 - 80 km/10min on the road.\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.