import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![,.])\\d+(?:[,.-]\\d+)? ?- ?\\d+(?:[,.]\\d+)? km ?\\/ ?(?:h|\\d+min)\\b";
final String string = "The car drives 50,5 - 80 km/10min on the road.\n"
+ "The car drives 50,5 - 80 km / 10min on the road.\n"
+ "The car drives 40,5-80 km/h on the road.\n"
+ "The car drives 30-50 km/h on the road.\n"
+ "The car drives 40 - 60.8 km/ h on the road.\n"
+ "The car drives 40.90-60,8 km/h on the road.\n"
+ "The car drives 50,5 - 80 km/10 on the road.\n"
+ "The car drives 505,000.2 - 80 km/10min on the road.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}