const regex = new RegExp('(?<![,.])\\d+(?:[,.-]\\d+)? ?- ?\\d+(?:[,.]\\d+)? km ?\\/ ?(?:h|\\d+min)\\b', 'gm')
const str = `The car drives 50,5 - 80 km/10min on the road.
The car drives 50,5 - 80 km / 10min on the road.
The car drives 40,5-80 km/h on the road.
The car drives 30-50 km/h on the road.
The car drives 40 - 60.8 km/ h on the road.
The car drives 40.90-60,8 km/h on the road.
The car drives 50,5 - 80 km/10 on the road.
The car drives 505,000.2 - 80 km/10min on the road.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}