const regex = /(?<=Amount Due|Pay This Amount|Total Balance|Total Current Month’s Charges|Amount Now Due|Amount Due|Amount due on|Total Balance on)\s+(\w+)?\s?\$([\d.,]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Amount Due|Pay This Amount|Total Balance|Total Current Month’s Charges|Amount Now Due|Amount Due|Amount due on|Total Balance on)\\s+(\\w+)?\\s?\\$([\\d.,]+)', 'gmi')
const str = `Pay this amount \$45.50
Pay this amount due Mar04 \$56.67 → Does not work with current expression
Amount due \$56.78 → works with current expression
Amount due on dec4 \$76.45 → does not work with current expression
Total balance \$76.45 → works with current expression
Total balance on apr3 \$64.34`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}