$re = '/(?<=Amount Due|Pay This Amount|Total Balance|Total Current Month’s Charges|Amount Now Due|Amount Due|Amount due on|Total Balance on)\s+(\w+)?\s?\$([\d.,]+)/mi';
$str = 'Pay this amount $45.50
Pay this amount due Mar04 $56.67 → Does not work with current expression
Amount due $56.78 → works with current expression
Amount due on dec4 $76.45 → does not work with current expression
Total balance $76.45 → works with current expression
Total balance on apr3 $64.34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);