using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([0-9]\)\s+([^.!?]+[.!?])";
string input = @"(1) This is my first sentence, it has to be captured. This is my second sentence.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}