package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\([0-9]\)\s+([^.!?]+[.!?])`)
var str = `(1) This is my first sentence, it has to be captured. This is my second sentence.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}