$re = '/\([0-9]\)\s+([^.!?]+[.!?])/';
$str = '(1) This is my first sentence, it has to be captured. This is my second sentence.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);