import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z\\d\\.\\+_'%-]+@([a-z\\d-]+\\.)+[a-z]{2,6}$";
final String string = "php\n"
+ "phpphpphpphpphp\n"
+ "pp\n"
+ "phhhhhhhhhp\n"
+ "PHP\n"
+ "pHp\n"
+ "pop\n"
+ "poop\n"
+ "p5p\n"
+ "p7p\n"
+ "p10p\n"
+ "p21p\n"
+ "p1p\n"
+ "p&p\n"
+ "p p\n"
+ "p p\n"
+ "p11p\n"
+ "+639993669426\n"
+ "09993669426\n"
+ "0324181445\n"
+ "+329925564856\n"
+ "099432442434\n"
+ "carlgarces7@gmail.com\n"
+ "robexample@example.com\n"
+ "CARLGARCES7@GMAIL.COM\n"
+ "ROBEXAMPLE@EXAMPLE.com.ph.edu.ph";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}