re = /^[a-z\d\.\+_'%-]+@([a-z\d-]+\.)+[a-z]{2,6}$/mi
str = 'php
phpphpphpphpphp
pp
phhhhhhhhhp
PHP
pHp
pop
poop
p5p
p7p
p10p
p21p
p1p
p&p
p p
p p
p11p
+639993669426
09993669426
0324181445
+329925564856
099432442434
carlgarces7@gmail.com
robexample@example.com
CARLGARCES7@GMAIL.COM
ROBEXAMPLE@EXAMPLE.com.ph.edu.ph'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end