import re
regex = re.compile(r"^[a-z\d\.\+_'%-]+@([a-z\d-]+\.)+[a-z]{2,6}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("php\n"
"phpphpphpphpphp\n"
"pp\n"
"phhhhhhhhhp\n"
"PHP\n"
"pHp\n"
"pop\n"
"poop\n"
"p5p\n"
"p7p\n"
"p10p\n"
"p21p\n"
"p1p\n"
"p&p\n"
"p p\n"
"p p\n"
"p11p\n"
"+639993669426\n"
"09993669426\n"
"0324181445\n"
"+329925564856\n"
"099432442434\n"
"carlgarces7@gmail.com\n"
"robexample@example.com\n"
"CARLGARCES7@GMAIL.COM\n"
"ROBEXAMPLE@EXAMPLE.com.ph.edu.ph")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")