// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[a-z\d\.\+_'%-]+@([a-z\d-]+\.)+[a-z]{2,6}$").unwrap();
let string = "php
phpphpphpphpphp
pp
phhhhhhhhhp
PHP
pHp
pop
poop
p5p
p7p
p10p
p21p
p1p
p&p
p p
p p
p11p
+639993669426
09993669426
0324181445
+329925564856
099432442434
carlgarces7@gmail.com
robexample@example.com
CARLGARCES7@GMAIL.COM
ROBEXAMPLE@EXAMPLE.com.ph.edu.ph";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}