using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"!\[[^\]]*\]\((?P<filename>.*?)(?=\""|\))(?P<optionalpart>\"".*\"")?\)";
string input = @"foo

bar
Group 1 will be image 2.png, and group 2 will be hello world.
The problem appears when I try to parse a link without title:
foo

bar";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}