import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "!\\[[^\\]]*\\]\\((?P<filename>.*?)(?=\\\"|\\))(?P<optionalpart>\\\".*\\\")?\\)";
final String string = "foo\n\n"
+ "\n\n"
+ "bar\n"
+ "Group 1 will be image 2.png, and group 2 will be hello world.\n\n"
+ "The problem appears when I try to parse a link without title:\n\n"
+ "foo\n\n"
+ "\n\n"
+ "bar";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}