# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"!\[[^\]]*\]\((?P<filename>.*?)(?=\"|\))(?P<optionalpart>\".*\")?\)"
test_str = ("foo\n\n"
"\n\n"
"bar\n"
"Group 1 will be image 2.png, and group 2 will be hello world.\n\n"
"The problem appears when I try to parse a link without title:\n\n"
"foo\n\n"
"\n\n"
"bar")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.