$re = '/!\[[^\]]*\]\((?P<filename>.*?)(?=\"|\))(?P<optionalpart>\".*\")?\)/';
$str = 'foo

bar
Group 1 will be image 2.png, and group 2 will be hello world.
The problem appears when I try to parse a link without title:
foo

bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);