#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\.(txt|pdf|csv|docx|html|jpeg)$)(?!.*\-bad\.\1$).+\.\1$"
Local $sString = "this-file-bad.txt" & @CRLF & _
"this-file.txt" & @CRLF & _
"this-file.txt_t" & @CRLF & _
".txt" & @CRLF & _
"f.txt" & @CRLF & _
"this-file-bad.csv" & @CRLF & _
"this-file.csv" & @CRLF & _
".csv" & @CRLF & _
"f.docx" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")