$re = '/^(?=.*\.(txt|pdf|csv|docx|html|jpeg)$)(?!.*\-bad\.\1$).+\.\1$/m';
$str = 'this-file-bad.txt
this-file.txt
this-file.txt_t
.txt
f.txt
this-file-bad.csv
this-file.csv
.csv
f.docx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);