const regex = /^(?=.*\.(txt|pdf|csv|docx|html|jpeg)$)(?!.*\-bad\.\1$).+\.\1$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\.(txt|pdf|csv|docx|html|jpeg)$)(?!.*\\-bad\\.\\1$).+\\.\\1$', 'gm')
const str = `this-file-bad.txt
this-file.txt
this-file.txt_t
.txt
f.txt
this-file-bad.csv
this-file.csv
.csv
f.docx
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}