import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\.(txt|pdf|csv|docx|html|jpeg)$)(?!.*\\-bad\\.\\1$).+\\.\\1$";
final String string = "this-file-bad.txt\n"
+ "this-file.txt\n"
+ "this-file.txt_t\n"
+ ".txt\n"
+ "f.txt\n"
+ "this-file-bad.csv\n"
+ "this-file.csv\n"
+ ".csv\n"
+ "f.docx\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}