#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?=[a-z0-9]{5,})(?=[a-z0-9]*[a-z])[a-z0-9]*[0-9][a-z0-9]*\b"
Local $sString = "abc1234aa121aaa" & @CRLF & _
"abc123" & @CRLF & _
"12abc123sd12" & @CRLF & _
"abcaaaaaa" & @CRLF & _
"ab12b12b12b2321b3" & @CRLF & _
"ab12b12b12b2321b" & @CRLF & _
"1abc1234aa121aaa" & @CRLF & _
"v2" & @CRLF & _
"44444"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")