import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=[a-z0-9]{5,})(?=[a-z0-9]*[a-z])[a-z0-9]*[0-9][a-z0-9]*\\b";
final String string = "abc1234aa121aaa\n"
+ "abc123\n"
+ "12abc123sd12\n"
+ "abcaaaaaa\n"
+ "ab12b12b12b2321b3\n"
+ "ab12b12b12b2321b\n"
+ "1abc1234aa121aaa\n"
+ "v2\n"
+ "44444";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}