$re = '/\b(?=[a-z0-9]{5,})(?=[a-z0-9]*[a-z])[a-z0-9]*[0-9][a-z0-9]*\b/m';
$str = 'abc1234aa121aaa
abc123
12abc123sd12
abcaaaaaa
ab12b12b12b2321b3
ab12b12b12b2321b
1abc1234aa121aaa
v2
44444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);