using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=[a-z0-9]{5,})(?=[a-z0-9]*[a-z])[a-z0-9]*[0-9][a-z0-9]*\b";
string input = @"abc1234aa121aaa
abc123
12abc123sd12
abcaaaaaa
ab12b12b12b2321b3
ab12b12b12b2321b
1abc1234aa121aaa
v2
44444";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}