import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sm)\\[json]:#\\s*\\((.*?)^\\)";
final String string = "[json]:# (\n"
+ "[\n"
+ " {\"jira\": \"proj-4753\"},\n"
+ " {\"creation\": \"2021-09-25\"}\n"
+ "]\n"
+ ")\n\n"
+ "# Title\n\n"
+ "## 1. Conclusion\n"
+ "Jada, jada\n\n"
+ "## 2. Recomendation\n"
+ "blah, blah\n\n"
+ "[json]:# (\n"
+ "[\n"
+ " {\"sensitivity\": \"internal\"}\n"
+ "]\n"
+ ")\n\n"
+ "More data\n\n"
+ "[json]:# (\n"
+ "[\n"
+ " {\"uid\": \"abc002334\"}\n"
+ "]\n"
+ ")\n"
+ "and this";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}