const regex = /(?sm)\[json]:#\s*\((.*?)^\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?sm)\\[json]:#\\s*\\((.*?)^\\)', 'g')
const str = `[json]:# (
[
{"jira": "proj-4753"},
{"creation": "2021-09-25"}
]
)
# Title
## 1. Conclusion
Jada, jada
## 2. Recomendation
blah, blah
[json]:# (
[
{"sensitivity": "internal"}
]
)
More data
[json]:# (
[
{"uid": "abc002334"}
]
)
and this`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);