re = /(?sm)\[json]:#\s*\((.*?)^\)/
str = '[json]:# (
[
{"jira": "proj-4753"},
{"creation": "2021-09-25"}
]
)
# Title
## 1. Conclusion
Jada, jada
## 2. Recomendation
blah, blah
[json]:# (
[
{"sensitivity": "internal"}
]
)
More data
[json]:# (
[
{"uid": "abc002334"}
]
)
and this'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result