import Foundation
let pattern = ##"(?sm)\[json]:#\s*\((.*?)^\)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ###"""
[json]:# (
[
{"jira": "proj-4753"},
{"creation": "2021-09-25"}
]
)
# Title
## 1. Conclusion
Jada, jada
## 2. Recomendation
blah, blah
[json]:# (
[
{"sensitivity": "internal"}
]
)
More data
[json]:# (
[
{"uid": "abc002334"}
]
)
and this
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)