#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)src='[^']*'(?=.*hero_img)"
Local $sString = "[av_image src='https://example.com/wp-content/uploads/2022/09/replace_this.jpg' attachment='1252' align='center' id=''][/av_image]" & @CRLF & _
"" & @CRLF & _
"[av_image src='http://example.com/wp-content/uploads/2022/09/dont_replace_this.jpg' attachment='560' align='center' id='hero_img'][/av_image]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")