use strict;
my $str = '[av_image src=\'https://example.com/wp-content/uploads/2022/09/replace_this.jpg\' attachment=\'1252\' align=\'center\' id=\'\'][/av_image]
[av_image src=\'http://example.com/wp-content/uploads/2022/09/dont_replace_this.jpg\' attachment=\'560\' align=\'center\' id=\'hero_img\'][/av_image]';
my $regex = qr/src='[^']*'(?=.*hero_img)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}