$re = '/src=\'[^\']*\'(?=.*hero_img)/m';
$str = '[av_image src=\'https://example.com/wp-content/uploads/2022/09/replace_this.jpg\' attachment=\'1252\' align=\'center\' id=\'\'][/av_image]
[av_image src=\'http://example.com/wp-content/uploads/2022/09/dont_replace_this.jpg\' attachment=\'560\' align=\'center\' id=\'hero_img\'][/av_image]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);