import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src='[^']*'(?=.*hero_img)";
final String string = "[av_image src='https://example.com/wp-content/uploads/2022/09/replace_this.jpg' attachment='1252' align='center' id=''][/av_image]\n\n"
+ "[av_image src='http://example.com/wp-content/uploads/2022/09/dont_replace_this.jpg' attachment='560' align='center' id='hero_img'][/av_image]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}