using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\x{0600}-\x{06FF}A-z-\d\/_.]+)?";
string input = @"English_Text/متن-فارسی/Numbers-0123456789/dot-./chars-_.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}