$re = '/([\x{0600}-\x{06FF}A-z-\d\/_.]+)?/m';
$str = 'English_Text/متن-فارسی/Numbers-0123456789/dot-./chars-_.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);