package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\x{0600}-\x{06FF}A-z-\d\/_.]+)?`)
var str = `English_Text/متن-فارسی/Numbers-0123456789/dot-./chars-_.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}